Remove dependencies to unused packages

Description

Several bundles in PerOpteryx claim to depend on bundles they never use, e.g.:

  1. de.uka.ipd.sdq.pcm.cost required in edu.kit.ipd.are.dsexplore.analysis.security, de.uka.ipd.sdq.dsexplore.analysis.security,  de.uka.ipd.sdq.pcm.designdecision.tests, edu.kit.ipd.are.dsexplore.featurecompletions, de.uka.ipd.sdq.dsexplore.analysis.nqr without real dependency

  2. org.palladiosimulator.mdsdprofiles required in **de.uka.ipd.sdq.dsexplore.analysis.nqr while only actual using the api bundle

check for and remove unused dependencies that hinder maintainability

Environment

None

Assignee

Anne Koziolek

Reporter

Jörg Henß

Labels

None

Requirement Category

None

External issue URL

None

Priority

Major