FCDSL incompatible with Xtext 2.22.0

Description

The project edu.kit.ipd.are.dsexplore.fcdsl.ide is incompatible with Xtext 2.22.0, which is shipped with Eclipse 2020-06. The build still works because the project is not built at all.

Fixing the compile error should be straight forward by regenerating the code with Xtext tooling. After that, the bundles should be added to the build. If the bundles are not used at all and not required anymore, it might be better to just remove them.

Environment

None

Activity

Show:
Stephan Seifermann
February 16, 2021, 2:47 PM

Pull request has been merged into master.

Stephan Seifermann
February 16, 2021, 2:38 PM

I regenerated the Xtext code and prepared a pull request.

Fixed

Assignee

Stephan Seifermann

Reporter

Stephan Seifermann

Labels

None

Requirement Category

None

External issue URL

None

Epic Link

Fix versions

Affects versions

Priority

Minor